FFDS Design Forum
http://www.aerodynamika.com/cgi-bin/yabb2/YaBB.pl
Design Forum >> Dave's Den: FSDSxTweak Support and Dave's Toys Board >> Specular problem, I think
http://www.aerodynamika.com/cgi-bin/yabb2/YaBB.pl?num=1373049842

Message started by daveh on 5th Jul, 2013 at 2:44pm

Title: Specular problem, I think
Post by daveh on 5th Jul, 2013 at 2:44pm
I do not think this is an FSDSxTweak problem, but I'm hoping for some help.

Got a fuselage, all textured, tweak file set up for bump and specular maps, compiles ok, runs through the Tweak ok. No problems. When I examine the x file the Tweaks have been applied as expected. All textures are dds and none are missing.
But in FSX, depending on the light or view angle, there is what appears to be a 'hard edge' or divide between the left and right halves, as if the textures for the left and right were different shades, which they are not.
Experimented by “removing” the textures by renaming them so FSX can not find them. What I found was:

No bump and no spec (main/diffuse texture only) – no hard edge
Main texture and spec only (no bump) – no hard edge
Main texture and bump only (no spec) – no hard edge
Main, spec and bump – hard edge

I have used the same tweak settings in other models and have not had this problem. Settings are:

[texture.3]
identifier=bellytank.bmp
diffuse=bellytank.dds
specular=bellytank_Spec.dds
bump=bellytank_Bump.dds
fresnel=Fresnel_Ramp.dds
environment_level_scale=0.65
bump_scale=1
UseGlobalEnvironment=1
BlendEnvironmentByInverseDiffuseAlpha=1
FresnelSpecular=1
FresnelEnvironment=1
SpecularMapPowerScale=100

Any ideas as to what the problem could be?

DaveH

Title: Re: Specular problem, I think
Post by daveh on 7th Jul, 2013 at 2:40pm
Found this which looks like the same problem -
Multimedia File Viewing and Clickable Links are available for Registered Members only!!  You need to Login or Register
Need to check the bump maps


FFDS Design Forum » Powered by YaBB 2.5 AE!
YaBB Forum Software © 2000-2010. All Rights Reserved.