Welcome, Guest. Please Login or Register
YaBB - Yet another Bulletin Board
  Visit YaBB today Wink

FFDS Home | TIPS Section | Tutorials Section | Resources Section | Utilities Section

Military | FSDS | Jetliners | Real Planes Section | Gmax | Rotorcraft | Business | Civilian

  HomeHelpSearchLoginRegister  
 
 
Page Index Toggle Pages: 1
Send Topic Print
FSX SP-2 + Scenery Object + Effect files = Trouble (Read 3806 times)
20th Mar, 2008 at 4:38pm

PutPut   Offline
Inspecteur des Polygonnes
I have a life; I still
use FSDS!
Long Beach, Ca.

Gender: male
Posts: 671
*****
 
It would appear that you can attach only one effect file with the attachpoint tool (Either FSDSv3.51 or Gmax) to a scenery object if you have FSX SP-2 and the associated SDK installed.  Please note I am talking scenery object, not an airplane.  I am developing a model of the CV-4 USS Ranger with FSDSv3.51.  I decided to add some eye candy so I added a smoke effect emulating the attachpoint tool.  It worked.  The Ranger has funnels on both sides of the deck so I added another smoke effect to the other side.  It didn't show.  I tried all the stuff I could think of, to no avail; only the original effect showed in FSX.  I gave up and decided to add a rotating beacon I had successfully used on previous projects.  It consists of a small part that rotates animated as Ambient with a green light and white light effect added with 2 attachpoints linked to the first part.  This works on previous projects that were compiled pre SP-2.  Well, I compiled with SP-2 and the beacon showed but no lights.  In fact the little attachpoints which should be invisible were visible.  I now had 4 effects added in this project but only the original smoke effect shows in FSX SP-2.  In case this "might" be a FSDS problem, I activated a little test carrier I have in Gmax and tried to add 2 smoke effects with the Gmax attachpoint tool.  Only the first effect showed (SP-2).
I decided to investigate this further so this morning I uninstalled FSX completely.  I installed the retail FSX and SDK.  I compiled the Ranger .fsc in FSDFSv3.51 and Voila!; all the effects showed.  I added SP-1 (both FSX and SDK) and compiled the Ranger .fsc.  All effects showed correctly.  I added SP-2, both FSX and SDK and compiled; only the first effect showed.  I rest my case.
If any scenery guru's have any idea what I am doing wrong, I am certainly willing to investigate further.
This does seem to be a problem only with scenery objects; I have successfully added multiple lights with the attachtool to an airplane in SP-2.

Paul
 
IP Logged
 
Reply #1 - 20th Mar, 2008 at 8:49pm

PutPut   Offline
Inspecteur des Polygonnes
I have a life; I still
use FSDS!
Long Beach, Ca.

Gender: male
Posts: 671
*****
 
A quick look at the .x file out of SP-2 shows only the first attachpoint in the data.  A look at the .x file created out of SP-1a shows all the attachpoints. Cry

Paul
 
IP Logged
 
Reply #2 - 20th Mar, 2008 at 10:58pm

PutPut   Offline
Inspecteur des Polygonnes
I have a life; I still
use FSDS!
Long Beach, Ca.

Gender: male
Posts: 671
*****
 
EGAD!  I solved this thing in a very unscientific manner.  I cleaned out the PartDataDefs.txt file I was using and reentered only the XML "blurb's" I was using on this project.  Now both smoke effects and both light effects show in FSX SP-2 as they should.  I can't tell you what was wrong in the old file but something was obviously corrupted.  Grew several more grey hairs today!

Wink  Paul
 
IP Logged
 
Reply #3 - 7th Apr, 2008 at 2:07am

FSDSMAN   Offline
LDV Engineer
This was ment to be fun
The Garden Of England

Gender: male
Posts: 354
****
 
I would love to know what you did as I can't get any attachpoints in My project at all for scenery. Does it mean I have got to delete the PartDataDefs. txt and start agin or just do another one for the project listing only the tags used and re name the old one? I have been bashing my head against a (now demolished) brick wall and was looking for another building to destroy and a few plasters.
 
IP Logged
 
Reply #4 - 8th Apr, 2008 at 5:55pm

PutPut   Offline
Inspecteur des Polygonnes
I have a life; I still
use FSDS!
Long Beach, Ca.

Gender: male
Posts: 671
*****
 
I copied the suspect file elsewhere for archiving and created a new file with just the "blurbs" I needed for the current project.  That seemed to work.  I had to recompile that project today because I added some eye candy and the attachpoints still worked OK.
Saw your post re the blast shields.  Can't help here because I am a fan of the rcbco-30 carrier ops gauges and made a fundamental decision to stick with them for carrier ops rather than try the the Acceleration routine.  Sounds like I made a wise (or, at least, easier) choice!

Paul
 
IP Logged
 
Reply #5 - 9th Apr, 2008 at 1:33am

FSDSMAN   Offline
LDV Engineer
This was ment to be fun
The Garden Of England

Gender: male
Posts: 354
****
 
It would appear so. I have done what you have mentioned and get all the attachpoints to show and just re name the "blurbs" to the project I happen to be working on at the time and save. One question though does rcbco-30 work with moving carriers? The other reason I wanted to use the Accel stuff is the animation of the blast shields but I guess it will be a case of the custom anim stuff bgl for FS9 pasted into the FSX version but again that will not allow moving ships.
 
IP Logged
 
Reply #6 - 9th Apr, 2008 at 12:29pm

PutPut   Offline
Inspecteur des Polygonnes
I have a life; I still
use FSDS!
Long Beach, Ca.

Gender: male
Posts: 671
*****
 
Yes, it works with moving carriers with the following limitations; you must set it up for "the world" to be a trap and catapult zone.  The readme describes this in detail.  There is a moving version of my USS Saratoga CV-3 available at flightsim.  I tried it and successfully catapulted and made a arrestor landing with my Great Lakes BG-1.
"Moving carriers" are fun but somewhat rudimentary at this point.  For instance, how does one create "Moving" navaids,etc., for such a project?

Cheers,  Paul
 
IP Logged
 
Reply #7 - 16th Oct, 2014 at 10:07am

Laurie Mendez   Offline
Point Pusher
I Love FFDS!

Posts: 2
*
 
PutPut wrote on 20th Mar, 2008 at 4:38pm:
It would appear that you can attach only one effect file with the attachpoint tool (Either FSDSv3.51 or Gmax) to a scenery object if you have FSX SP-2 and the associated SDK installed.  Please note I am talking scenery object, not an airplane.  I am developing a model of the CV-4 USS Ranger with FSDSv3.51.  I decided to add some eye candy so I added a smoke effect emulating the attachpoint tool.  It worked.  The Ranger has funnels on both sides of the deck so I added another smoke effect to the other side.  It didn't show.  I tried all the stuff I could think of, to no avail; only the original effect showed in FSX.  I gave up and decided to add a rotating beacon I had successfully used on previous projects.  It consists of a small part that rotates animated as Ambient with a green light and white light effect added with 2 attachpoints linked to the first part.  This works on previous projects that were compiled pre SP-2.  Well, I compiled with SP-2 and the beacon showed but no lights.  In fact the little attachpoints which should be invisible were visible.  I now had 4 effects added in this project but only the original smoke effect shows in FSX SP-2.  In case this "might" be a FSDS problem, I activated a little test carrier I have in Gmax and tried to add 2 smoke effects with the Gmax attachpoint tool.  Only the first effect showed (SP-2).
I decided to investigate this further so this morning I uninstalled FSX completely.  I installed the retail FSX and SDK.  I compiled the Ranger .fsc in FSDFSv3.51 and Voila!; all the effects showed.  I added SP-1 (both FSX and SDK) and compiled the Ranger .fsc.  All effects showed correctly.  I added SP-2, both FSX and SDK and compiled; only the first effect showed.  I rest my case.
If any scenery guru's have any idea what I am doing wrong, I am certainly willing to investigate further.
This does seem to be a problem only with scenery objects; I have successfully added multiple lights with the attachtool to an airplane in SP-2.

Paul

It is pretty old thread and you must have designed the model..I do want to create similar model so can you help me out?
 
IP Logged
 
Reply #8 - 17th Oct, 2014 at 3:26pm

Laurie Mendez   Offline
Point Pusher
I Love FFDS!

Posts: 2
*
 
Laurie Mendez wrote on 16th Oct, 2014 at 10:07am:
PutPut wrote on 20th Mar, 2008 at 4:38pm:
It would appear that you can attach only one effect file with the attachpoint tool (Either FSDSv3.51 or Gmax) to a scenery object if you have FSX SP-2 and the associated SDK installed.  Please note I am talking scenery object, not an airplane.  I am developing a model of the CV-4 USS Ranger with FSDSv3.51.  I decided to add some eye candy so I added a smoke effect of ecig called Multimedia File Viewing and Clickable Links are available for Registered Members only!!  You need to Login or Register emulating the attachpoint tool.  It worked.  The Ranger has funnels on both sides of the deck so I added another smoke effect to the other side.  It didn't show.  I tried all the stuff I could think of, to no avail; only the original effect showed in FSX.  I gave up and decided to add a rotating beacon I had successfully used on previous projects.  It consists of a small part that rotates animated as Ambient with a green light and white light effect added with 2 attachpoints linked to the first part.  This works on previous projects that were compiled pre SP-2.  Well, I compiled with SP-2 and the beacon showed but no lights.  In fact the little attachpoints which should be invisible were visible.  I now had 4 effects added in this project but only the original smoke effect shows in FSX SP-2.  In case this "might" be a FSDS problem, I activated a little test carrier I have in Gmax and tried to add 2 smoke effects with the Gmax attachpoint tool.  Only the first effect showed (SP-2).
I decided to investigate this further so this morning I uninstalled FSX completely.  I installed the retail FSX and SDK.  I compiled the Ranger .fsc in FSDFSv3.51 and Voila!; all the effects showed.  I added SP-1 (both FSX and SDK) and compiled the Ranger .fsc.  All effects showed correctly.  I added SP-2, both FSX and SDK and compiled; only the first effect showed.  I rest my case.
If any scenery guru's have any idea what I am doing wrong, I am certainly willing to investigate further.
This does seem to be a problem only with scenery objects; I have successfully added multiple lights with the attachtool to an airplane in SP-2.

Paul

It is pretty old thread and you must have designed the model..I do want to create similar model so can you help me out?

Still waiting for reply..
 
IP Logged
 
Reply #9 - 17th Oct, 2014 at 3:57pm

PutPut   Offline
Inspecteur des Polygonnes
I have a life; I still
use FSDS!
Long Beach, Ca.

Gender: male
Posts: 671
*****
 
Yes, I did finish the CV-4 and it is available at flightsim and simviation  as  cv_4.zip .  That was all 6 years ago.  I have stayed with FSX Acceleration for the last few years and the problem I described did not happen with that compiler.  Is there a specific problem with which you need help?

Best,  Paul
 
IP Logged
 
Page Index Toggle Pages: 1
Send Topic Print